summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-04 22:24:52 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-06 00:08:06 -0400
commitdb753d642083e3c59a3959c1c408c2d14e29dd27 (patch)
treee8df7f71b59ceb775683fe996a35924f716c59cd /gnu
parentd4f65bc4ba0890f32155f0cb1711df6c09772ccd (diff)
downloadguix-db753d642083e3c59a3959c1c408c2d14e29dd27.tar.gz
gnu: python-mdit-py-plugins: Update to 0.3.1.
* gnu/packages/python-xyz.scm (python-mdit-py-plugins): Update to 0.3.1.
[source]: Fetch from git.
[build-system]: Use pyproject-build-system.
[propagated-inputs]: Add python-attrs.
[native-inputs]: Add python-flit-core.
[description]: Remove extraneous white space.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 18 insertions, 16 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 37807cbcdb..3cffe0b74e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -744,27 +744,30 @@ that best match text queries.")
 (define-public python-mdit-py-plugins
   (package
     (name "python-mdit-py-plugins")
-    (version "0.3.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "mdit-py-plugins" version))
-       (sha256
-        (base32
-         "0l4pwsn2q30j160zjg79qa8v2brc4zl295rgrkpbfspcxr8lzhpc"))))
-    (build-system python-build-system)
-    (propagated-inputs (list python-markdown-it-py))
+    (version "0.3.1")
+    (source (origin
+              (method git-fetch)        ;for tests
+              (uri (git-reference
+                    (url "https://github.com/executablebooks/mdit-py-plugins")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "00ybbfb6dzn9q5qnvnm8bmhd84s215ik7pcdb4r35zhwiv2ikizz"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs
+     (list python-markdown-it-py
+           python-attrs))
     (native-inputs
      (list python-coverage
+           python-flit-core
            python-pytest
            python-pytest-cov
            python-pytest-regressions))
     (home-page "https://github.com/executablebooks/mdit-py-plugins")
     (synopsis "Collection of plugins for markdown-it-py")
-    (description
-     "This package contains a collection of plugins for @code{markdown-it-py}
-like:
-
+    (description "This package contains a collection of plugins for
+@code{markdown-it-py} like:
 @enumerate
 @item amsmath,
 @item attrs,
@@ -775,8 +778,7 @@ like:
 @item footnote,
 @item textmath, and
 @item wordcount.
-@end enumerate
-")
+@end enumerate")
     (license license:expat)))
 
 (define-public python-mdurl