summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 19:45:57 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 20:25:29 +0200
commitdb82b442f2055c176845e004fa895aa890dfe7f1 (patch)
treed9b69bbe859d625cb6b7a0a0dd6e9482eb69a9ce /gnu
parentbfe5ea96e57f5337015ebb59630cecc4a1610ccd (diff)
downloadguix-db82b442f2055c176845e004fa895aa890dfe7f1.tar.gz
gnu: Add texlive-poetrytex.
* gnu/packages/tex.scm (texlive-poetrytex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 69d37eea64..6efab395ee 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10582,6 +10582,49 @@ way, and with a few additional abilities, such as facilities for a list of
 poems, an index of first lines, and some structural commands.")
     (license license:lppl1.3c)))
 
+(define-public texlive-poetrytex
+  (package
+    (name "texlive-poetrytex")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/poetrytex/"
+                   "source/latex/poetrytex/"
+                   "tex/latex/poetrytex/")
+             (base32
+              "1y78zd1hd3z1901x6mc6q0mw4rgj3qcqhnjn34zix11r0gn4b2jr")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments
+     (list #:tex-format "latex"
+           #:phases
+           #~(modify-phases %standard-phases
+               ;; Replace "\code{...}" with "\texttt{...}" (which is the alias
+               ;; chosen in the documentation) in order to prevent a "Command
+               ;; \code already defined" error.
+               (add-after 'unpack 'fix-documentation-source
+                 (lambda _
+                   (substitute* "source/latex/poetrytex/poetrytex.dtx"
+                     (("\\\\newcommand\\*\\\\code\\[1\\].*") "")
+                     (("\\\\code\\{") "\\texttt{")))))))
+    (native-inputs
+     (list (texlive-updmap.cfg
+            (list texlive-etoolbox
+                  texlive-fancyvrb
+                  texlive-framed
+                  texlive-hologo
+                  texlive-hypdoc
+                  texlive-parskip
+                  texlive-tipa
+                  texlive-tocloft))))
+    (home-page "https://ctan.org/pkg/poetrytex")
+    (synopsis "Typeset anthologies of poetry")
+    (description
+     "The package is designed to aid in the management and formatting of
+anthologies of poetry and other writings; it does not concern itself with
+actually typesetting the verse itself.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-polexpr
   (package
     (name "texlive-polexpr")