summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 16:13:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:11 +0200
commitdbd5df621dc9fe12317c71bb457939e61152cff0 (patch)
tree1b0bc69c59a1e198e911e5c7f199d2207ffe7c0d /gnu
parente325aacc499c7f1e0a89284fc27e0668570501fb (diff)
downloadguix-dbd5df621dc9fe12317c71bb457939e61152cff0.tar.gz
gnu: Add texlive-memoir.
* gnu/packages/tex.scm (texlive-memoir): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index daf275f2a3..b2262a2a6a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10391,6 +10391,29 @@ environments;
 @end itemize")
     (license license:lppl1.3c)))
 
+(define-public texlive-memoir
+  (package
+    (name "texlive-memoir")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/memoir/" "makeindex/memoir/"
+                   "source/latex/memoir/" "tex/latex/memoir/")
+             (base32
+              "10jf0kiwvgrki8az04b57v0ffm6b3jj1rz3q6fgxhnrbsd68iphr")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/memoir")
+    (synopsis "Typeset fiction, non-fiction and mathematical books")
+    (description
+     "The @code{memoir} class is for typesetting poetry, fiction,
+non-fiction, and mathematical works.  Permissible document base font sizes
+range from 9 to 60pt.  There is a range of page-styles and well over a dozen
+chapter-styles to choose from, as well as methods for specifying your own
+layouts and designs.  The class also provides the functionality of over thirty
+of the more popular packages, thus simplifying document sources.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-fp
   (package
     (name "texlive-fp")