summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:00:17 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:51 +0200
commitdbf280c06b8a6293399a86298e76cba065dc7f07 (patch)
treedcc2bb5b5a256fed40c90dc22c809e43bdebab5a /gnu
parent8a29fb69916ad579df47dbb7d9f444e663b07bb4 (diff)
downloadguix-dbf280c06b8a6293399a86298e76cba065dc7f07.tar.gz
gnu: Add texlive-scale.
* gnu/packages/tex.scm (texlive-scale): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 86eb167252..578f43afae 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -94568,6 +94568,27 @@ typesetting rules, but there are also options subtle, moderate and extreme
 options for the broad brush approach.")
     (license license:lppl1.3+)))
 
+(define-public texlive-scale
+  (package
+    (name "texlive-scale")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/scale/" "source/latex/scale/"
+                   "tex/latex/scale/")
+             (base32
+              "150dm7w2nlqfrhi71xnnmi92mrhdn7lbpnnsz22r0z71wk95qb26")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/scale")
+    (synopsis "Scale document by sqrt(2) or magstep(2)")
+    (description
+     "This package provides a package to scale a document by sqrt(2) (or by
+@code{\\magstep@{2@}}).  This is useful if you are preparing a document on,
+for example, A5 paper and want to print on A4 paper to achieve a better
+resolution.")
+    (license license:gpl3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar