summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-02-09 23:10:49 +0100
committerLudovic Courtès <ludo@gnu.org>2017-02-10 00:13:55 +0100
commitdc7010911dd3285fe9089352e92c77501595d100 (patch)
treee2588b7bce06c0580cb6d729abdc7beae2c441dc /gnu
parent8fd6850436eb1b291d099b8b5c84f00c5d67e242 (diff)
downloadguix-dc7010911dd3285fe9089352e92c77501595d100.tar.gz
gnu: emacs: Adjust 'tramp-remote-path' for remote GuixSD machines.
* gnu/packages/emacs.scm (emacs)[source](snippet): Patch
'net/tramp-sh.el'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index dfdf324960..b361fcc4a5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -110,7 +110,18 @@
                                    (find-files "." "loaddefs\\.el$")
                                    ;; This is the only "autoloads" file that
                                    ;; does not have "*loaddefs.el" name.
-                                   '("eshell/esh-groups.el")))))))
+                                   '("eshell/esh-groups.el")))
+
+                 ;; Make sure Tramp looks for binaries in the right places on
+                 ;; remote GuixSD machines, where 'getconf PATH' returns
+                 ;; something bogus.
+                 (substitute* "net/tramp-sh.el"
+                   ;; Patch the line after "(defcustom tramp-remote-path".
+                   (("\\(tramp-default-remote-path")
+                    (format #f "(tramp-default-remote-path ~s ~s ~s ~s "
+                            "~/.guix-profile/bin" "~/.guix-profile/sbin"
+                            "/run/current-system/profile/bin"
+                            "/run/current-system/profile/sbin")))))))
     (build-system glib-or-gtk-build-system)
     (arguments
      `(#:phases