summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2015-05-06 15:08:47 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-05-07 10:54:12 -0400
commitdc77f0d321be96a8f6817dbd33f5414d333d7fba (patch)
treef57d9e4406b7006fc925516eb389c57f0d75455d /gnu
parente5c8e4f3618e003ffee87f42deb0d3b3311bff6a (diff)
downloadguix-dc77f0d321be96a8f6817dbd33f5414d333d7fba.tar.gz
gnu: Add openvpn.
* gnu/packages/vpn.scm (openvpn): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/vpn.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 5883f99505..62036d9ef7 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -28,6 +28,7 @@
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gnutls)
+  #:use-module (gnu packages linux)
   #:use-module (gnu packages openssl)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
@@ -125,3 +126,33 @@ supported by the ASA5500 Series, by IOS 12.4(9)T or later on Cisco SR500,
 and probably others.")
    (license license:lgpl2.1)
    (home-page "http://www.infradead.org/openconnect/")))
+
+(define-public openvpn
+  (package
+    (name "openvpn")
+    (version "2.3.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://swupdate.openvpn.org/community/releases/openvpn-"
+                    version ".tar.xz"))
+              (sha256
+               (base32
+                "1v8h2nshxnvn2zyr08vzkfby1kc7ma6bi0s6hix389cj9krjxbmd"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags '("--enable-iproute2=yes")))
+    (native-inputs
+     `(("iproute2" ,iproute)))
+    (inputs
+     `(("lzo" ,lzo)
+       ("openssl" ,openssl)
+       ("linux-pam" ,linux-pam)))
+    (home-page "https://openvpn.net/")
+    (synopsis "Virtual private network daemon")
+    (description "OpenVPN implements virtual private network (VPN) techniques
+for creating secure point-to-point or site-to-site connections in routed or
+bridged configurations and remote access facilities.  It uses a custom
+security protocol that utilizes SSL/TLS for key exchange.  It is capable of
+traversing network address translators (NATs) and firewalls. ")
+    (license license:gpl2)))