summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-12 13:49:04 +0100
committerMarius Bakke <marius@gnu.org>2021-12-12 23:26:02 +0100
commitdd5851e0880f801ab425483196c30c94af762082 (patch)
tree27f0f89121174688d80976e14a4e4e5fb08e755c /gnu
parent2ac8a13a6a1c816ccf40da378e49e470cc72203d (diff)
downloadguix-dd5851e0880f801ab425483196c30c94af762082.tar.gz
gnu: mps-youtube: Disable sanity check.
* gnu/packages/video.scm (mps-youtube)[arguments]: Add #:phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 23128efc70..da8dab56b1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3842,7 +3842,11 @@ Content System specification.")
      ;; test suite results differ depending on the country and also introduce
      ;; non-determinism in the tests.
      ;; https://github.com/mps-youtube/mps-youtube/issues/556
-     `(#:tests? #f))
+     '(#:tests? #f
+       #:phases (modify-phases %standard-phases
+                  ;; Loading this as a library will create cache directories,
+                  ;; etc; which fails in the build container.
+                  (delete 'sanity-check))))
     (propagated-inputs
      `(("python-pafy" ,python-pafy)
        ("python-pygobject" ,python-pygobject))) ; For mpris2 support