summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2024-02-28 15:30:46 +0100
committerjgart <jgart@dismail.de>2024-06-22 14:45:15 -0500
commitdd5ef2cbddd76cf048a9b514cdcea6d22411a2cb (patch)
tree324b01a9a35c1b756a327ff6a203bc240ff803b6 /gnu
parent018f2781d5aa301c156c81981f1fd3df56e438b9 (diff)
downloadguix-dd5ef2cbddd76cf048a9b514cdcea6d22411a2cb.tar.gz
gnu: Add python-sqlalchemy-2.
* gnu/packages/databases.scm (python-sqlalchemy-2): New variable.

Change-Id: I6de8a9d9ab5938b6d7129f884fe31902df828889
Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/databases.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 3d2a9c309e..7854188eb0 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3643,6 +3643,53 @@ designed for efficient and high-performing database access, adapted into a
 simple and Pythonic domain language.")
     (license license:x11)))
 
+(define-public python-sqlalchemy-2
+  (package
+    (name "python-sqlalchemy")
+    (version "2.0.27")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "SQLAlchemy" version))
+       (sha256
+        (base32 "1y1l4lwhvgs7ivwhcp4vljjdsaha77x9859kz65virhzlxlyv9l6"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-pytest))
+    (propagated-inputs (list python-typing-extensions))
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'disable-tests
+            (lambda _
+              ;; Remove expensive tests.
+              (for-each delete-file
+                        '("test/ext/mypy/test_mypy_plugin_py3k.py"
+                          "test/typing/test_mypy.py"
+                          "test/aaa_profiling/test_memusage.py"))
+              (substitute* "test/engine/test_pool.py"
+                ;; Disable a test that fails randomly.
+                (("def test_recycle_pool_no_race")
+                 "def _test_recycle_pool_no_race"))))
+          ;; According to the pyproject.toml, greenlet is optional.
+          (add-after 'unpack 'remove-dependency-on-greenlet
+            (lambda _
+              (substitute* "setup.cfg"
+                (("greenlet != 0.4.17")
+                 "#greenlet != 0.4.17"))
+              (substitute* "PKG-INFO"
+                (("Requires-Dist: greenlet")
+                 "#Requires-Dist: greenlet")))))))
+    (home-page "https://www.sqlalchemy.org")
+    (synopsis "SQL toolkit and object relational mapper")
+    (description
+     "SQLAlchemy is the Python SQL toolkit and @acronym{ORM, Object Relational Mapper}
+that gives application developers the full power and flexibility of SQL.  It provides
+a full suite of well known enterprise-level persistence patterns, designed for
+efficient and high-performing database access, adapted into a simple and Pythonic
+domain language.")
+    (license license:expat)))
+
 (define-public python-sqlalchemy-stubs
   (package
     (name "python-sqlalchemy-stubs")