summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-03-26 14:04:50 -0400
committerLudovic Courtès <ludo@gnu.org>2022-03-29 11:30:25 +0200
commitddfebdab86178af7e434a73a6dd9fab733522245 (patch)
tree2002be1d5ddf89613072c4c474dbef06fa8c8992 /gnu
parent39b27a17ec8f6d7dddbb4406947e8cc70abdf790 (diff)
downloadguix-ddfebdab86178af7e434a73a6dd9fab733522245.tar.gz
gnu: poezio: Update to 0.13.2.
* gnu/packages/messaging.scm (poezio): Update to 0.13.2.
[arguments]: Remove trailing boolean and use new style.
[inputs]: Remove unused python input.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index f40c3a7e2c..2e1aa30ae9 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -466,7 +466,7 @@ TCP sessions from existing clients.")
 (define-public poezio
   (package
     (name "poezio")
-    (version "0.13.1")
+    (version "0.13.2")
     (source
      (origin
        (method git-fetch)
@@ -478,17 +478,16 @@ TCP sessions from existing clients.")
        (file-name
         (git-file-name name version))
        (sha256
-        (base32 "041y61pcbdb86s04qwp8s1g6bp84yskc7vdizwpi2hz18y01x5fy"))))
+        (base32 "0p92k8ssjsgavyfv1fd5cgzyw87dmdd84vaz7zvfsf5crvpr1mkf"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch
-           (lambda _
-             (substitute* "setup.py"
-               (("'CC', 'cc'")
-                "'CC', 'gcc'"))
-             #t)))))
+      (list #:phases
+            #~(modify-phases %standard-phases
+                (add-after 'unpack 'patch
+                  (lambda _
+                    (substitute* "setup.py"
+                      (("'CC', 'cc'")
+                       "'CC', 'gcc'")))))))
     (native-inputs
      (list pkg-config python-setuptools python-sphinx))
     (inputs
@@ -498,7 +497,6 @@ TCP sessions from existing clients.")
            python-pyasn1-modules
            python-pygments
            python-pyinotify
-           ;("python" ,python)
            python-qrcode
            python-slixmpp))
     (synopsis "Console Jabber/XMPP Client")