summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2017-10-11 18:05:24 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-10-11 21:44:06 +0200
commitde47cfed13982ad14fc4854cb04a7600002b4964 (patch)
treee253891bf53ba7180739a91c458046d91b98bfce /gnu
parent01d87d3c180963a0ad615abaebd0d6c533b0fc4f (diff)
downloadguix-de47cfed13982ad14fc4854cb04a7600002b4964.tar.gz
gnu: bluez: Disable unpredictable test on armhf.
* gnu/packages/linux.scm (bluez): [arguments] Add phase to skip a test instead
of marking it as XFAIL.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d1420ee824..97a294ac20 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3051,6 +3051,16 @@ Bluetooth audio output devices like headphones or loudspeakers.")
                (string-append "--with-udevdir=" out "/lib/udev")))
        #:phases
        (modify-phases %standard-phases
+         ,@(if (string=? (%current-system) "armhf-linux")
+               ;; This test fails unpredictably.
+               ;; TODO: skip it for all architectures.
+               `((add-before 'check 'skip-wonky-test
+                  (lambda _
+                    (substitute* "unit/test-gatt.c"
+                      (("tester_init\\(&argc, &argv\\);") "return 77;"))
+                    #t)))
+               `())
+
          (add-after 'install 'post-install
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out        (assoc-ref outputs "out"))
@@ -3069,12 +3079,7 @@ Bluetooth audio output devices like headphones or loudspeakers.")
                   (string-append out "/lib/udev/hid2hci --method"))
                  (("/sbin/udevadm")
                   (string-append (assoc-ref inputs "eudev") "/bin/udevadm")))
-               #t))))
-
-       ;; FIXME: Skip one test that segfaults on ARM.
-       ,@(if (string=? (%current-system) "armhf-linux")
-             '(#:make-flags '("XFAIL_TESTS=unit/test-gatt"))
-             '())))
+               #t))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("gettext" ,gettext-minimal)))