summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-14 18:02:11 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-19 23:32:33 +0000
commitde55f2146056d21061c7c9a541532b0280c4c01b (patch)
treed2c55846736fbd8831c7a8898151ae35f8935f87 /gnu
parentd3d87b93d204b6f441ddde2d8460c6bf7818b8d0 (diff)
downloadguix-de55f2146056d21061c7c9a541532b0280c4c01b.tar.gz
gnu: go-github-go-git: Adjust imports.
* gnu/packages/version-control.scm (go-github-go-git) [native-inputs]:
Move go-github-com-alcortesm-tgz, go-github-com-emirpasic-gods,
go-github-com-go-git-gcfg, go-github-com-go-git-go-billy,
go-github-com-go-git-go-git-fixtures, go-github-com-imdario-mergo,
go-github-com-jbenet-go-context, go-github-com-kevinburke-ssh-config,
go-github-com-mitchellh-go-homedir, go-github-com-sergi-go-diff,
go-github-com-xanzy-ssh-agent, go-golang-org-x-crypto,
go-golang-org-x-net, go-golang-org-x-text, go-gopkg-in-check-v1 and
go-gopkg-in-warnings from here ...
[propagated-inputs]: ... to here.

Change-Id: I9c16fe28dcbbaf7c53e201625f56a04bceb21fcb
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 31a4bfb973..f683bc4e0e 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -3621,10 +3621,12 @@ defects faster.")
                (invoke git-exe "config" "--global" "user.name" "GitHub Actions")
                #t)
              #t)))))
-    (native-inputs
-     (list go-github-com-emirpasic-gods
+    (propagated-inputs
+     (list go-github-com-alcortesm-tgz
+           go-github-com-emirpasic-gods
            go-github-com-go-git-gcfg
            go-github-com-go-git-go-billy
+           go-github-com-go-git-go-git-fixtures
            go-github-com-imdario-mergo
            go-github-com-jbenet-go-context
            go-github-com-kevinburke-ssh-config
@@ -3633,12 +3635,10 @@ defects faster.")
            go-github-com-xanzy-ssh-agent
            go-golang-org-x-crypto
            go-golang-org-x-net
-           go-gopkg-in-warnings
-           go-github-com-go-git-go-git-fixtures
-           go-gopkg-in-check-v1
-           go-github-com-alcortesm-tgz
            go-golang-org-x-text
-           git))
+           go-gopkg-in-check-v1
+           go-gopkg-in-warnings))
+    (native-inputs (list git))
     (home-page "https://github.com/go-git/")
     (synopsis "Git implementation library")
     (description "This package provides a Git implementation library.")