summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Dvorsak <eric@dvorsak.fr>2015-07-25 21:36:51 +0200
committerAlex Kost <alezost@gmail.com>2015-07-31 10:59:31 +0300
commitde73dbf62d2696746f6de9dce79b1fe537c51613 (patch)
tree1a76ef5023ebfc01d22abfc95fd16ee05ca62bd7 /gnu
parent670398751e982bfc17cc6c1f2bf155a9ca7c9bce (diff)
downloadguix-de73dbf62d2696746f6de9dce79b1fe537c51613.tar.gz
gnu: Add python-httplib2.
* gnu/packages/python.scm (python-httplib2, python-httplib2): New variables.

Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 817b6cdd1b..ab89fd0d60 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -298,6 +298,34 @@ pidof, tty, taskset, pmap.")
 (define-public python2-psutil
   (package-with-python2 python-psutil))
 
+(define-public python-httplib2
+  (package
+    (name "python-httplib2")
+    (version "0.9.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/h/httplib2/httplib2-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1xc3clbrf77r0600kja71j7hk1218sjiq0gfmb8vjdajka8kjqxw"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (home-page
+     "https://github.com/jcgregorio/httplib2")
+    (synopsis "Comprehensive HTTP client library")
+    (description
+     "A comprehensive HTTP client library supporting many features left out of
+other HTTP libraries.")
+    (license license:expat)))
+
+(define-public python2-httplib2
+  (package-with-python2 python-httplib2))
+
 (define-public python-ecdsa
   (package
     (name "python-ecdsa")