summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-07 22:49:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-08 18:30:38 +0300
commitdecdb5a59d0b1316d53564712b543a718c1f627c (patch)
tree95e42b4f86ac60bb22abf85e53afc1ecd8bad360 /gnu
parent675c5c9bbd28e5e666903aa81efaec25b1573811 (diff)
downloadguix-decdb5a59d0b1316d53564712b543a718c1f627c.tar.gz
gnu: bash-completion: Remove util-linux overrides.
These completions are deprecated or removed upstream, and
bash-completion defers to upstream completions.

* gnu/packages/bash.scm (bash-completion)[native-inputs]: Remove field.
[arguments]: Remove field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bash.scm29
1 files changed, 1 insertions, 28 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 97891f5cb6..080db6acfb 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -310,35 +310,8 @@ variant logs the history to syslog.")))
               (patches
                (search-patches "bash-completion-directories.patch"))))
     (build-system gnu-build-system)
-    (native-inputs (list util-linux))
     (arguments
-     `(#:tests? #f      ; Unclear how to make tests pass.
-       #:phases (modify-phases %standard-phases
-                  (add-after
-                   'install 'remove-redundant-completions
-                   (lambda* (#:key
-                             inputs native-inputs
-                             outputs #:allow-other-keys)
-                     ;; Util-linux comes with a bunch of completion files for
-                     ;; its own commands which are more sophisticated and
-                     ;; up-to-date than those of bash-completion.  Remove those
-                     ;; from bash-completion.
-                     (let* ((out         (assoc-ref outputs "out"))
-                            (util-linux  (assoc-ref (or native-inputs inputs)
-                                                    "util-linux"))
-                            (completions (string-append out
-                                                        "/share/bash-completion"
-                                                        "/completions"))
-                            (already     (find-files
-                                          (string-append
-                                           util-linux
-                                           "/etc/bash_completion.d"))))
-                       (with-directory-excursion completions
-                         (for-each (lambda (file)
-                                     (when (file-exists? file)
-                                       (delete-file file)))
-                                   (map basename already)))
-                       #t))))))
+     `(#:tests? #f))    ; Unclear how to make tests pass.
     (synopsis "Bash completions for common commands")
     (description
      "This package provides extensions that allow Bash to provide adapted