summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-02-20 01:00:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-20 01:00:01 +0100
commite1a4770fb07cfcea7c0c03d880ac253167a24d6d (patch)
tree568f17d1f7fa4e886a389608fb9a943248b787f2 /gnu
parente680c4086178c03eea58c1e987ea2216653dbd6a (diff)
downloadguix-e1a4770fb07cfcea7c0c03d880ac253167a24d6d.tar.gz
gnu: pspp: Fix failing test suite.
* gnu/packages/statistics.scm (pspp)[arguments]: Add a new 'prepare-tests phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index bf384726de..f32183bf89 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -34,6 +34,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages statistics)
+  #:use-module (guix gexp)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -109,6 +110,14 @@
        (base32
         "0lqrash677b09zxdlxp89z6k02y4i23mbqg83956dwl69wc53dan"))))
     (build-system gnu-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'check 'prepare-tests
+                 ;; Prevent irrelevant errors that cause test output mismatches:
+                 ;; ‘Fontconfig error: No writable cache directories’
+                 (lambda _
+                   (setenv "XDG_CACHE_HOME" (getcwd)))))))
     (inputs
      (list cairo
            gettext-minimal