summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-06-25 15:07:33 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-06-27 14:58:59 +0200
commite366b94f9fd1338a94e80e83d0b060fac65ad2f4 (patch)
tree10110929eaf9860a5d98e03b0784b90071fd296d /gnu
parent41aec416ce8a18f4ba764757103ea9524a30959d (diff)
downloadguix-e366b94f9fd1338a94e80e83d0b060fac65ad2f4.tar.gz
gnu: Add ocaml-uri-sexp.
* gnu/packages/ocaml.scm (ocaml-uri-sexp): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0eb63b94d4..560d8d2036 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7071,6 +7071,21 @@ Graphics.open_graph is called.  This library used to be distributed with OCaml
 up to OCaml 4.08.")
     (license license:lgpl2.1+)))
 
+(define-public ocaml-uri-sexp
+  (package
+    (inherit ocaml-uri)
+    (name "ocaml-uri-sexp")
+    (arguments
+     '(#:package "uri-sexp"
+       #:test-target "."))
+    (propagated-inputs
+      `(("ocaml-uri" ,ocaml-uri)
+        ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
+        ("ocaml-sexplib0" ,ocaml-sexplib0)))
+    (native-inputs `(("ocaml-ounit" ,ocaml-ounit)))
+    (synopsis "RFC3986 URI/URL parsing library")
+    (description "This package adds S-exp support to @code{ocaml-uri}.")))
+
 (define-public js-of-ocaml
   (package
     (name "js-of-ocaml")