summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-02 21:02:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:03 +0200
commite36e59495bce844fbc501102fa5a2e881dce75b3 (patch)
tree04e337e6a81baa79a3e60087377343ea4a6935bc /gnu
parent3c249e52d1816c3e350d3df4f4bb03561bc3e78c (diff)
downloadguix-e36e59495bce844fbc501102fa5a2e881dce75b3.tar.gz
gnu: Add rust-faster-hex-0.9.
* gnu/packages/crates-io.scm (rust-faster-hex-0.9): New variable.
(rust-faster-hex-0.8): Inherit from rust-faster-hex-0.9.

Change-Id: I55772d8a6e3ea72d70543d335f5e09599fe87b25
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm34
1 files changed, 28 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 81e13c6c3e..899efa3cd5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -24617,8 +24617,35 @@ is defined in the HTML specification.")
 floats.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-faster-hex-0.9
+  (package
+    (name "rust-faster-hex")
+    (version "0.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "faster-hex" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "10wi4vqbdpkamw4qvra1ijp4as2j7j1zc66g4rdr6h0xv8gb38m2"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-serde" ,rust-serde-1))
+       #:cargo-development-inputs (("rust-bytes" ,rust-bytes-1)
+                                   ("rust-criterion" ,rust-criterion-0.3)
+                                   ("rust-hex" ,rust-hex-0.3)
+                                   ("rust-proptest" ,rust-proptest-1)
+                                   ("rust-rustc-hex" ,rust-rustc-hex-1)
+                                   ("rust-serde" ,rust-serde-1)
+                                   ("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/NervosFoundation/faster-hex")
+    (synopsis "Fast hex encoding")
+    (description "Fast hex encoding.")
+    (license license:expat)))
+
 (define-public rust-faster-hex-0.8
   (package
+    (inherit rust-faster-hex-0.9)
     (name "rust-faster-hex")
     (version "0.8.1")
     (source
@@ -24628,7 +24655,6 @@ floats.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "12ikld53h5d682rn1j85d77n90pq4vy5mncwdaqhm0hgjgxpp7r3"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-serde" ,rust-serde-1))
@@ -24639,11 +24665,7 @@ floats.")
         ("rust-proptest" ,rust-proptest-1)
         ("rust-rustc-hex" ,rust-rustc-hex-1)
         ("rust-serde" ,rust-serde-1)
-        ("rust-serde-json" ,rust-serde-json-1))))
-    (home-page "https://github.com/nervosnetwork/faster-hex")
-    (synopsis "Fast hex encoding")
-    (description "Fast hex encoding.")
-    (license license:expat)))
+        ("rust-serde-json" ,rust-serde-json-1))))))
 
 (define-public rust-fastq-0.6
   (package