summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-12-29 01:40:42 -0500
committerLeo Famulari <leo@famulari.name>2017-12-29 01:53:51 -0500
commite3cea0d5e4c227a7f0a3db0f85c75431ccaa6eec (patch)
treef700041d48b7890f37c4b4fefcd9550e067848cb /gnu
parent315430d7df7b6f12664c9aa541147816edfea964 (diff)
downloadguix-e3cea0d5e4c227a7f0a3db0f85c75431ccaa6eec.tar.gz
gnu: lynx: Update to 2.8.9dev.16 [fixes CVE-2017-1000211].
* gnu/packages/web-browsers.scm (lynx): Update to 2.8.9dev.16.
[arguments]: Patch the path of the shell in the translations makefile.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web-browsers.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 95d2878835..bd4c34efb6 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -130,7 +130,7 @@ features including, tables, builtin image display, bookmarks, SSL and more.")
 (define-public lynx
   (package
     (name "lynx")
-    (version "2.8.9dev.15")
+    (version "2.8.9dev.16")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -138,7 +138,7 @@ features including, tables, builtin image display, bookmarks, SSL and more.")
                     "/lynx" version ".tar.bz2"))
               (sha256
                (base32
-                "16bdr7ai130ps67px8ssxnjxp5j6m4rin3in7jm22fxk0a8p2428"))))
+                "1j0vx871ghkm7fgrafnvd2ml3ywcl8d3gyhq02fhfb851c88lc84"))))
     (build-system gnu-build-system)
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("perl" ,perl)))
@@ -169,6 +169,10 @@ features including, tables, builtin image display, bookmarks, SSL and more.")
        #:tests? #f  ; no check target
        #:phases
        (modify-phases %standard-phases
+         (add-before 'configure 'set-makefile-shell
+           (lambda _ (substitute* "po/makefile.inn"
+                       (("/bin/sh") (which "sh")))
+                     #t))
          (replace 'install
            (lambda* (#:key (make-flags '()) #:allow-other-keys)
              (zero? (apply system* "make" "install-full" make-flags)))))))