summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 20:35:09 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commite510a263acf14284449b5bcb75db6935f51e8cad (patch)
tree1ee86dd33587e06286a5b49088077e99d70625a6 /gnu
parentfc3d355df7d67201d1486ea1f86fa0121804f7af (diff)
downloadguix-e510a263acf14284449b5bcb75db6935f51e8cad.tar.gz
gnu: kde-frameworks: Add breeze-icons.
* gnu/packages/kde-frameworks.scm (breeze-icons): New variable.

Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 97114cf783..e6dc1aa5ab 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -140,6 +140,33 @@ http://freedesktop.org/wiki/Specifications/open-collaboration-services/")
 Bluetooth stack.  It is used by the KDE Bluetooth stack, BlueDevil.")
     (license (list license:lgpl2.1+ license:lgpl3+))))
 
+(define-public breeze-icons
+  (package
+    (name "breeze-icons")
+    (version "5.24.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "mirror://kde/stable/frameworks/"
+                            (version-major+minor version) "/"
+                            name "-" version ".tar.xz"))
+        (sha256
+         (base32
+          "1dh7bijx99sdb3vn6394wmm5cq0fvvmz8h17sx4hakmbga849cx2"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("qtbase" ,qtbase)))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Default KDE Plasma 5 icon theme")
+    (description "Breeze provides a freedesktop.org compatible icon theme.
+It is the default icon theme for the KDE Plasma 5 desktop.")
+    ;; The license file mentions lgpl3+. The license files in the source
+    ;; directories are lgpl3, while the top directory contains the lgpl2.1.
+    ;; text.
+    (license license:lgpl3+)))
+
 (define-public kwindowsystem
   (package
     (name "kwindowsystem")