summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2022-04-17 04:57:15 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2022-04-17 05:03:00 -0400
commite5174200c4d78358e22e889da2b53dc06c202003 (patch)
treec5c53eefcad9fce653cb08246916553f2f355572 /gnu
parent0c89fe9e17dc9e628c73959289464ac5f146c7cd (diff)
downloadguix-e5174200c4d78358e22e889da2b53dc06c202003.tar.gz
gnu: gnucash: Update to 4.10.
Variables gnucash and gnucash-docs have to be updated together.

* gnu/packages/gnucash.scm (gnucash)[version]: Update to 4.10.
(gnucash-docs)[version]: Update to 4.10.
[build-system]: Migrate from gnu to cmake.
[arguments]: Disable tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnucash.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index ee7ca3cfde..ec50c8aaa6 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -63,14 +63,14 @@
   ;; directory.
   (package
     (name "gnucash")
-    (version "4.6")
+    (version "4.10")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
                            version "/gnucash-" version ".tar.bz2"))
        (sha256
-        (base32 "0csp8iddhc901vv09gl5lj970g6ili696vwj4vdpkiprp7gh26r5"))))
+        (base32 "0fy9p5fgi2i0x7acg5fnkfdrxxd3dypi3ykvnj53hfbfky8vpm3z"))))
     (build-system cmake-build-system)
     (inputs
      `(("guile" ,guile-3.0)
@@ -229,10 +229,10 @@ installed as well as Yelp, the Gnome help browser.")
        (origin
          (method url-fetch)
          (uri (string-append "mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
-                             version "/gnucash-docs-" version revision ".tar.gz"))
+                             version "/gnucash-docs-" version ".1" revision ".tar.gz"))
          (sha256
-          (base32 "1365k4wb8zfm2zyg7zqyvajbzh9311m2zi1vpvbpp8p4sibqjksw"))))
-      (build-system gnu-build-system)
+          (base32 "0cf2m1lgpq6if89w8anz522nar5kwpfzi0kacymw17m42fzxz0cg"))))
+      (build-system cmake-build-system)
       ;; These are native-inputs because they are only required for building the
       ;; documentation.
       (native-inputs
@@ -243,6 +243,8 @@ installed as well as Yelp, the Gnome help browser.")
          ("libxslt" ,libxslt)
          ("docbook-xsl" ,docbook-xsl)
          ("scrollkeeper" ,scrollkeeper)))
+      (arguments
+       `(#:tests? #f)) ;no test target
       (home-page "https://www.gnucash.org/")
       (synopsis "Documentation for GnuCash")
       (description