summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-27 18:01:31 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-27 19:03:21 +0200
commite58d05c32ecab9e08d3819538f0b0ea970232713 (patch)
tree2bb6c9a26a7bff2b5361bbc007a597717242ffe2 /gnu
parentf9caa17b633c1760758afc2f12bc7b1e80d7bf53 (diff)
downloadguix-e58d05c32ecab9e08d3819538f0b0ea970232713.tar.gz
gnu: ocaml-csv: Update to 2.2.
* gnu/packages/ocaml.scm (ocaml-csv): Update to 2.2.
[source]: Use git-fetch.
[build-system]: Use dune-build-system.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0e3df64264..9766bb4b20 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1554,20 +1554,21 @@ coexistence with the old (version 2) SQLite and its OCaml wrapper
 (define-public ocaml-csv
   (package
     (name "ocaml-csv")
-    (version "1.6")
+    (version "2.2")
     (source
      (origin
-       (method url-fetch)
-       (uri
-        (string-append
-         "https://github.com/Chris00/ocaml-csv/releases/download/"
-         version "/csv-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/Chris00/ocaml-csv")
+              (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0rv7x843vn6scxj87hzl01yqrl26rc27lr8s7z6rp9vs745g05zj"))))
-    (build-system ocaml-build-system)
-    (native-inputs
-     `(("ocamlbuild" ,ocamlbuild)))
+         "07qdw8bbvprk78x96pnm807rhs82ks6sxis1cf5nyng8b5nvm2mv"))))
+    (build-system dune-build-system)
+    (arguments
+     `(#:package "csv"
+       #:test-target "."))
     (home-page "https://github.com/Chris00/ocaml-csv")
     (synopsis "Pure OCaml functions to read and write CSV")
     (description