summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-05-30 20:58:43 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 14:52:22 +0300
commite5b8a87b40710590421915bec0d0c161b684b9fc (patch)
treebb10bcdfc4804ffed1cfe150ad360f26762cb641 /gnu
parent2ff1c352d4032a588f4b0d8ebe0eb3e946fbc3e1 (diff)
downloadguix-e5b8a87b40710590421915bec0d0c161b684b9fc.tar.gz
gnu: Add python-stpipe.
* gnu/packages/astronomy.scm (python-stpipe): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index ac4b6eea96..5c42512a0a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2216,6 +2216,29 @@ the @acronym{JWST, James Webb Space Telescope} and @acronym{Roman, Nancy Grace
 Roman Space Telescope} calibration software.")
     (license license:bsd-3)))
 
+(define-public python-stpipe
+  (package
+    (name "python-stpipe")
+    (version "0.5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "stpipe" version))
+              (sha256
+               (base32
+                "17gnwzhl10vbg059lfprdyci19dlh3whkmb9rl7z25wr593rnvcp"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-asdf python-astropy python-crds
+                             python-semantic-version python-stdatamodels))
+    (native-inputs (list python-pytest python-pytest-doctestplus
+                         python-pytest-openfiles python-setuptools-scm))
+    (home-page "https://github.com/spacetelescope/stpipe")
+    (synopsis "Framework for calibration pipeline software")
+    (description
+     "This package provides base classes and command-line tools for
+implementing calibration pipeline software.")
+    ;; LICENSE Association of Universities for Research in Astronomy (AURA)
+    (license license:bsd-3)))
+
 (define-public python-stsynphot
   (package
     (name "python-stsynphot")