summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-02-09 17:38:03 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-09 17:48:05 +0100
commite6034e3cf8d662d35b5de903b93916e2d2292e0d (patch)
tree58b71342831196b94b5f377572f4cb84431cdcef /gnu
parent3f95ac9188293e26f40fff500b91f2a603524dfc (diff)
downloadguix-e6034e3cf8d662d35b5de903b93916e2d2292e0d.tar.gz
gnu: Add direwolf.
* gnu/packages/radio.scm (direwolf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/radio.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index c3f1c0c933..5ceae146ba 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1188,3 +1188,43 @@ NanoVNA vector network analyzers.")
 (sometimes called DSSTV).  It is compatible with most of MMSSTV and EasyPal.")
     (license (list license:gpl2+
                    license:qwt1.0))))
+
+(define-public direwolf
+  (package
+    (name "direwolf")
+    (version "1.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/wb2osz/direwolf")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0xmz64m02knbrpasfij4rrq53ksxna5idxwgabcw4n2b1ig7pyx5"))))
+    (build-system cmake-build-system)
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("hamlib" ,hamlib)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-paths
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* "conf/CMakeLists.txt"
+               (("DESTINATION /etc")
+                (string-append "DESTINATION "
+                               (assoc-ref outputs "out")
+                               "/etc"))))))))
+    (home-page "https://github.com/wb2osz/direwolf")
+    (synopsis "TNC for Amateur Packet Radio")
+    (description
+     "Dire Wolf is a Terminal Node Controller (TNC) for Amateur Packet Radio.
+It can perform as:
+@itemize
+@item APRS GPS tracker,
+@item Digipeater,
+@item Internet gateway (IGate)
+@item APRStt gateway
+@end itemize\n")
+    (license license:gpl2+)))