summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-11-09 19:02:46 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-11-09 19:02:46 +0100
commite60bbd9a5b5fa195e22a18a742b1c330f62c8bcc (patch)
treef517ed6430492ea27cd69183ee859e7ee5a7804e /gnu
parentf66fbb7a51415b1c08d8c03d1d1869715c10901d (diff)
downloadguix-e60bbd9a5b5fa195e22a18a742b1c330f62c8bcc.tar.gz
gnu: Add custom-hash-table.
* gnu/packages/lisp-xyz.scm (cl-custom-hash-table, ecl-custom-hash-table,
sbcl-custom-hash-table): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 80e4b0b9ee..1b3ce0ba38 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -14306,3 +14306,36 @@ mostly not found in other utility packages.")
 
 (define-public ecl-agutil
   (sbcl-package->ecl-package sbcl-agutil))
+
+(define-public sbcl-custom-hash-table
+  (let ((commit "f26983133940f5edf826ebbc8077acc04816ddfa"))
+    (package
+      (name "sbcl-custom-hash-table")
+      (version (git-version "0.3" "1" commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/metawilm/cl-custom-hash-table")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1k4mvrpbqqds2fwjxp1bxmrfmr8ch4dkwhnkbw559knbqshvrlj5"))))
+      (build-system asdf-build-system/sbcl)
+      (arguments
+       '(#:asd-file "cl-custom-hash-table.asd"
+         #:asd-system-name "cl-custom-hash-table"))
+      (home-page "https://github.com/metawilm/cl-custom-hash-table")
+      (synopsis "Custom hash tables for Common Lisp")
+      (description "This library allows creation of hash tables with arbitrary
+@code{test}/@code{hash} functions, in addition to the @code{test} functions
+allowed by the standard (@code{EQ}, @code{EQL}, @code{EQUAL} and
+@code{EQUALP}), even in implementations that don't support this functionality
+directly.")
+      (license license:expat))))
+
+(define-public cl-custom-hash-table
+  (sbcl-package->cl-source-package sbcl-custom-hash-table))
+
+(define-public ecl-custom-hash-table
+  (sbcl-package->ecl-package sbcl-custom-hash-table))