summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:11:56 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:19 +0200
commite64a9baad0511ad8b78cc0d475dfa0f53a395a90 (patch)
tree59c8177e97c33360d2763652c179171a8d1c1900 /gnu
parent1de8da85a0385e396443c4074da927be751101cb (diff)
downloadguix-e64a9baad0511ad8b78cc0d475dfa0f53a395a90.tar.gz
gnu: Add texlive-chemnum.
* gnu/packages/tex.scm (texlive-chemnum): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 760b406025..8a6fe0f902 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2359,6 +2359,24 @@ includes some nomenclature commands, oxidation numbers, thermodynamic data,
 newman projections, etc.")
     (license license:lppl1.3c)))
 
+(define-public texlive-chemnum
+  (package
+    (name "texlive-chemnum")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/chemnum/" "tex/latex/chemnum/")
+             (base32
+              "0ld2ja2by5y48v5k8x1mgmcpr75vkf8r8ni0fmvrpxh8xrv7mq4f")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/chemnum")
+    (synopsis "Method for numbering chemical compounds")
+    (description
+     "The package defines a @code{\\label}- and @code{\\ref}-like commands for
+compound numbers.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-chronosys
   (package
     (name "texlive-chronosys")