summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-05 17:19:54 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-05 23:36:03 +0100
commite6bd8b5e1def33beac3b6b4eb2f1f525f87ad0ea (patch)
tree696fc7a36df00b841986ac93c51571ffe42b9b55 /gnu
parentebb7cf9e21060105d9950dd5142c0eb918083666 (diff)
downloadguix-e6bd8b5e1def33beac3b6b4eb2f1f525f87ad0ea.tar.gz
gnu: zziplib: Incorporate grafted changes.
* gnu/packages/compression.scm (zziplib)[replacement]: Remove.
[source](patches): New field.
(zziplib/fixed): Remove variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 1f76f9ac1e..b2edca4cd4 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1580,13 +1580,13 @@ recreates the stored directory structure by default.")
   (package
     (name "zziplib")
     (version "0.13.69")
-    (replacement zziplib/fixed)
     (home-page "https://github.com/gdraheim/zziplib")
     (source (origin
               (method git-fetch)
               (uri (git-reference (url home-page)
                                   (commit (string-append "v" version))))
               (file-name (git-file-name name version))
+              (patches (search-patches "zziplib-CVE-2018-16548.patch"))
               (sha256
                (base32
                 "0fbk9k7ryas2wh2ykwkvm1pbi40i88rfvc3dydh9xyd7w2jcki92"))))
@@ -1618,13 +1618,6 @@ recreates the stored directory structure by default.")
     ;; files carry the Zlib license; see "docs/copying.html" for details.
     (license (list license:lgpl2.0+ license:mpl1.1))))
 
-(define zziplib/fixed
-  (package
-    (inherit zziplib)
-    (source (origin
-              (inherit (package-source zziplib))
-              (patches (search-patches "zziplib-CVE-2018-16548.patch"))))))
-
 (define-public libzip
   (package
     (name "libzip")