summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-18 19:29:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-01-21 19:38:51 +0100
commite7a30ded59f314023a7d3e6c16a098b7e8e20c2c (patch)
tree47459b621537e85273617883e8d17e90ec2bc817 /gnu
parenta15181bbdb3428362695bc8f80f256d006b357f0 (diff)
downloadguix-e7a30ded59f314023a7d3e6c16a098b7e8e20c2c.tar.gz
gnu: Add python2-graphite-web.
* gnu/packages/monitoring.scm (python2-graphite-web): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/monitoring.scm48
1 files changed, 47 insertions, 1 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 1a5cc0414c..d7a1641ad8 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -28,11 +28,14 @@
   #:use-module (gnu packages admin)
   #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages django)
   #:use-module (gnu packages gd)
   #:use-module (gnu packages image)
   #:use-module (gnu packages mail)
   #:use-module (gnu packages perl)
-  #:use-module (gnu packages python))
+  #:use-module (gnu packages python)
+  #:use-module (gnu packages python-web)
+  #:use-module (gnu packages time))
 
 (define-public nagios
   (package
@@ -215,3 +218,46 @@ Graphite.  Carbon is responsible for receiving metrics over the network,
 caching them in memory for \"hot queries\" from the Graphite-Web application,
 and persisting them to disk using the Whisper time-series library.")
     (license license:asl2.0)))
+
+(define-public python2-graphite-web
+  (package
+    (name "python2-graphite-web")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "graphite-web" version))
+       (sha256
+        (base32
+         "0q8bwlj75jqyzmazfsi5sa26xl58ssa8wdxm2l4j0jqyn8xpfnmc"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:python ,python-2               ; only supports Python 2
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'relax-requirements
+           (lambda _
+             (substitute* "setup.py"
+               (("0.4.3") ,(package-version python2-django-tagging))
+               (("<1.9.99") (string-append "<="
+                             ,(package-version python2-django))))
+             #t))
+         ;; Don't install to /opt
+         (add-after 'unpack 'do-not-install-to-/opt
+           (lambda _ (setenv "GRAPHITE_NO_PREFIX" "1") #t)))))
+    (propagated-inputs
+     `(("python2-cairocffi" ,python2-cairocffi)
+       ("python2-pytz" ,python2-pytz)
+       ("python2-whisper" ,python2-whisper)
+       ("python2-django" ,python2-django)
+       ("python2-django-tagging" ,python2-django-tagging)
+       ("python2-scandir" ,python2-scandir)
+       ("python2-urllib3" ,python2-urllib3)
+       ("python2-pyparsing" ,python2-pyparsing)
+       ("python2-txamqp" ,python2-txamqp)))
+    (home-page "http://graphiteapp.org/")
+    (synopsis "Scalable realtime graphing system")
+    (description "Graphite is a scalable real-time graphing system that does
+two things: store numeric time-series data, and render graphs of this data on
+demand.")
+    (license license:asl2.0)))