summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:02:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:31 +0200
commite7aa62ef0b21f1d63ede86629cee19ef979a1c64 (patch)
treee32989e065beaf9915c6067e69e477a8da291cd6 /gnu
parentbecf40315cfde507ab10b6caf96d19fbf0b54a32 (diff)
downloadguix-e7aa62ef0b21f1d63ede86629cee19ef979a1c64.tar.gz
gnu: Add texlive-substitutefont.
* gnu/packages/tex.scm (texlive-substitutefont): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a573c5c67e..2356a550ab 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96792,6 +96792,27 @@ which generates sub-figures within one normal figure, and manages their
 placement; @code{subfloat} only affects captions and numbering.")
     (license license:lppl)))
 
+(define-public texlive-substitutefont
+  (package
+    (name "texlive-substitutefont")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/substitutefont/"
+                   "tex/latex/substitutefont/")
+             (base32
+              "12h6012ckkacv2hjcs0cv3ylzzxfp54ps0ca2fp6m20achbv93lc")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/substitutefont")
+    (synopsis "Easy font substitution")
+    (description
+     "Many fonts are extensions of a basic font family with new glyphs or shapes.
+Such fonts may be given a new name due to licence reasons or to the creator's
+preference.  The package facilitates the task of setting up a font family as
+substitute for another one, using its @code{\\substitutefont} command.")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar