summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-12 18:53:36 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-13 00:17:37 +0200
commite7c67f1b69c373d6504928d52382b483e555e7f2 (patch)
tree99f5d98a94b53988d6851eecf44ce2beb7f7b54e /gnu
parent5f7e3ac066e75ac98d218b0a38bbc240ad8ff9c7 (diff)
downloadguix-e7c67f1b69c373d6504928d52382b483e555e7f2.tar.gz
gnu: python-oauthlib: Propagate required inputs.
* gnu/packages/python-web.scm (python-oauthlib)[native-inputs]: Move
PYTHON-CRYPTOGRAPHY, PYTHON-PYJWT, and PYTHON-BLINKER ...
[propagated-inputs]: ... here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index af04219514..e5993164cd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1443,8 +1443,9 @@ with python-requests.")
     (build-system python-build-system)
     (native-inputs
      `(("python-nose" ,python-nose)
-       ("python-mock" ,python-mock)
-       ("python-cryptography" ,python-cryptography)
+       ("python-mock" ,python-mock)))
+    (propagated-inputs
+     `(("python-cryptography" ,python-cryptography)
        ("python-pyjwt" ,python-pyjwt)
        ("python-blinker" ,python-blinker)))
     (home-page "https://github.com/oauthlib/oauthlib")