summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-17 19:47:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-17 20:02:17 +0100
commite823337c6eb9ab99e0e3311d4c8024cb220afd08 (patch)
tree8b4e774c8307d25fdaa0a754442ea4389f19ac31 /gnu
parent40fe63ad8a3578a2a7090ee18fcb3d35096ba8c8 (diff)
downloadguix-e823337c6eb9ab99e0e3311d4c8024cb220afd08.tar.gz
gnu: Add r-rsbml.
* gnu/packages/bioconductor.scm (r-rsbml): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index beb46c9ded..4e7bfc582a 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6678,3 +6678,31 @@ tests the null hypothesis that the target regions have the same probability of
 having footprints for the TF k as the background regions while correcting for
 the read count and GC content bias.")
     (license license:gpl3)))
+
+(define-public r-rsbml
+  (package
+    (name "r-rsbml")
+    (version "2.44.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "rsbml" version))
+       (sha256
+        (base32
+         "1dbp0aaijxn3na26b68ws0v9qzvml61ifb9z4i8pz7q6h48n7lxa"))))
+    (properties `((upstream-name . "rsbml")))
+    (build-system r-build-system)
+    (inputs
+     `(("libsbml" ,libsbml)
+       ("zlib" ,zlib)))
+    (propagated-inputs
+     `(("r-biocgenerics" ,r-biocgenerics)
+       ("r-graph" ,r-graph)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://www.sbml.org")
+    (synopsis "R support for SBML")
+    (description
+     "This package provides an R interface to libsbml for SBML parsing,
+validating output, provides an S4 SBML DOM, converts SBML to R graph objects.")
+    (license license:artistic2.0)))