summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-17 22:17:55 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-17 22:55:04 -0400
commite8ab1ba7c2d842c53d42f94d0ab5c2550d7e0e9d (patch)
tree0b3a80c444de1fad05ec9b6d6eb94a66dec08ce7 /gnu
parent15badf7b1eb7b9bf44977d07845154bc3baaeb2c (diff)
downloadguix-e8ab1ba7c2d842c53d42f94d0ab5c2550d7e0e9d.tar.gz
gnu: lxrandr: Build with GTK 3.
* gnu/packages/lxde.scm (lxrandr)[configure-flags]: New argument.
[inputs]: Remove labels.  Replace gtk+-2 with gtk+.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lxde.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 9fcd6e1414..e840f1c969 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -139,7 +139,8 @@ able to change themes, icons, and fonts used by GTK+ applications.")
                 "04n3vgh3ix12p8jfs4w0dyfq3anbjy33h7g53wbbqqc0f74xyplb"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
+     `(#:configure-flags (list "--enable-gtk3")
+       #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'xrandr-absolutely
            ;; lxrandr is useless without xrandr and gives an unhelpful error
@@ -147,9 +148,8 @@ able to change themes, icons, and fonts used by GTK+ applications.")
            (lambda* (#:key input #:allow-other-keys)
              (substitute* "src/lxrandr.c"
                (("(\"|')xrandr\"" _ match)
-                (string-append match (which "xrandr") "\"")))
-             #t)))))
-    (inputs (list gtk+-2 xrandr))
+                (string-append match (which "xrandr") "\""))))))))
+    (inputs (list gtk+ xrandr))
     (native-inputs (list intltool pkg-config))
     (synopsis "LXDE monitor configuration tool")
     (description "LXRandR is a very basic monitor configuration tool.  It