summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-10-18 11:02:23 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-10-18 11:20:31 +0200
commite970f72cb1333591bd7c2ccdce1c2838e55b678f (patch)
treece867783d6162722dfec2813c8c49779ccaad06a /gnu
parent2d24ba34ed6d1473110afc758dfe74b819fd3513 (diff)
downloadguix-e970f72cb1333591bd7c2ccdce1c2838e55b678f.tar.gz
gnu: Add python-yattag.
* gnu/packages/python-xyz.scm (python-yattag): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 19352b41dc..732a548d99 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -33990,6 +33990,23 @@ functions
 markdown-compliant strings.")
     (license license:expat)))
 
+(define-public python-yattag
+  (package
+    (name "python-yattag")
+    (version "1.15.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "yattag" version))
+       (sha256
+        (base32 "05p4dgdp8wwvnsvcv7n4zn8k602w345kw4vq67s9d792w55sa3wn"))))
+    (build-system python-build-system)
+    (synopsis "HTML or XML generator for Python")
+    (description
+     "Yattag is a Python library for generating HTML or XML in a pythonic way.")
+    (home-page "https://www.yattag.org/")
+    (license license:lgpl2.1)))
+
 (define-public python-zbarlight
   (package
     (name "python-zbarlight")