summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-01-14 22:44:53 +0100
committerLudovic Courtès <ludo@gnu.org>2019-01-14 23:43:49 +0100
commite98c354d1ad8e0751421b0a3a6c15bd784017501 (patch)
tree0c3a92a67d6c4b66718e2dc5aa11e2f1fea160c5 /gnu
parenta8b0556ea1e439c89dc1ba33c8864e8b9b811f08 (diff)
downloadguix-e98c354d1ad8e0751421b0a3a6c15bd784017501.tar.gz
gnu: guile-ssh: Use 'git-fetch'.
* gnu/packages/ssh.scm (guile-ssh)[source]: Change to 'git-fetch'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ssh.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index ce77a1aa60..5d0d76648a 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -235,16 +235,14 @@ Additionally, various channel-specific options can be negotiated.")
     (version "0.11.3")
     (home-page "https://github.com/artyom-poptsov/guile-ssh")
     (source (origin
-              ;; ftp://memory-heap.org/software/guile-ssh/guile-ssh-VERSION.tar.gz
-              ;; exists, but the server appears to be too slow and unreliable.
-              ;; Also, using this URL allows the GitHub updater to work.
-              (method url-fetch)
-              (uri (string-append home-page "/archive/v"
-                                  version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "1g2jzcg1p25zrkx06j160qb8bgcwa3001ys4q02496xs61pvywqk"))
+                "03bv3hwp2s8f0bqgfjaan9jx4dyab0abv27n2zn2g0izlidv0vl6"))
               (modules '((guix build utils)))
               (snippet
                '(begin