summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:42 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:38:56 -0500
commitea94cb36d6568491a75dbd783dd1bb691821b8a5 (patch)
tree4d4c1535e6b394c3cae9007358ef0433016b6381 /gnu
parent972c1245c6e7595bd26a2ca279c750d2ccd76e1c (diff)
downloadguix-ea94cb36d6568491a75dbd783dd1bb691821b8a5.tar.gz
gnu: go-github-com-getsentry-raven-go: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-getsentry-raven-go): Move from
here...
* gnu/packages/golang-web.scm: ...to here.

Change-Id: If7e155b3e85d8bda8fd099f6a4d1eb6b87e9eee3
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm31
-rw-r--r--gnu/packages/golang.scm27
2 files changed, 31 insertions, 27 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index c046e0d46a..41c8c37a0b 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -9,6 +9,7 @@
 ;;; Copyright © 2020 raingloom <raingloom@riseup.net>
 ;;; Copyright © 2020-2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2021 Collin J. Doering <collin@rekahsoft.ca>
+;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
@@ -45,6 +46,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages golang)
   #:use-module (gnu packages golang-check)
+  #:use-module (gnu packages tls)
   #:use-module (gnu packages web))
 
 ;;; Commentary:
@@ -521,6 +523,35 @@ decode/encode structures and slices.")
     (home-page "https://github.com/francoispqt/gojay")
     (license license:expat)))
 
+;; TODO: This repository has been archived by the owner on Aug 30, 2023. It is
+;; now read-only. The raven-go SDK is no longer maintained and was superseded
+;; by the sentry-go
+(define-public go-github-com-getsentry-raven-go
+  (let ((commit "5c24d5110e0e198d9ae16f1f3465366085001d92")
+        (revision "0"))
+    (package
+      (name "go-github-com-getsentry-raven-go")
+      (version (git-version "0.2.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/getsentry/raven-go")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0lvc376sq8r8jhy2v1m6rf1wyld61pvbk0x6j9xpg56ivqy69xs7"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/getsentry/raven-go"))
+      (propagated-inputs
+       (list go-github-com-certifi-gocertifi go-github-com-pkg-errors))
+      (home-page "https://github.com/getsentry/raven-go")
+      (synopsis "Sentry client in Go")
+      (description "This package is a Go client API for the Sentry event/error
+logging system.")
+      (license license:bsd-3))))
+
 (define-public go-github-com-go-chi-chi-v5
   (package
     (name "go-github-com-go-chi-chi-v5")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0fbc031c67..dcf7fcc2a8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4174,33 +4174,6 @@ loading algorithms.")
 is similar to Go's standard library @code{json} and @code{xml} package.")
     (license license:expat)))
 
-(define-public go-github-com-getsentry-raven-go
-  (let ((commit "5c24d5110e0e198d9ae16f1f3465366085001d92")
-        (revision "0"))
-    (package
-      (name "go-github-com-getsentry-raven-go")
-      (version (git-version "0.2.0" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/getsentry/raven-go")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "0lvc376sq8r8jhy2v1m6rf1wyld61pvbk0x6j9xpg56ivqy69xs7"))))
-      (build-system go-build-system)
-      (arguments
-       '(#:import-path "github.com/getsentry/raven-go"))
-      (propagated-inputs
-       (list go-github-com-certifi-gocertifi go-github-com-pkg-errors))
-      (home-page "https://github.com/getsentry/raven-go")
-      (synopsis "Sentry client in Go")
-      (description "This package is a Go client API for the Sentry event/error
-logging system.")
-      (license license:bsd-3))))
-
 (define-public go-github-com-hashicorp-go-uuid
   (package
     (name "go-github-com-hashicorp-go-uuid")