summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-04-25 00:09:59 +0200
committerAndreas Enge <andreas@enge.fr>2014-04-25 00:09:59 +0200
commiteb78797163abc06f032ac76a6c8a1e6e579b9de4 (patch)
tree10e77617bb2df24e6a922e92ca371e192040398d /gnu
parent436d4d1fbb425c26d716e9f789f1284ec088cc86 (diff)
downloadguix-eb78797163abc06f032ac76a6c8a1e6e579b9de4.tar.gz
gnu: libdbusmenu-qt: Add native input doxygen for building the documentation,
  and make input qjson native.

* gnu/packages/kde.scm (libdbusmenu-qt): Add native input doxygen for
    building the documentation.
    Make input qjson native, as it is needed only for the tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 320bcd9d1a..bc5d2d533a 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -22,6 +22,7 @@
   #:use-module (guix download)
   #:use-module (guix build-system cmake)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages doxygen)
   #:use-module (gnu packages geeqie)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages perl)
@@ -123,14 +124,13 @@ while JSON objects are mapped to QVariantMap.")
                "1v0ri5g9xw2z64ik0kx0ra01v8rpjn2kxprrxppkls1wvav1qv5f"))))
     (build-system cmake-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(("doxygen" ,doxygen) ; used for static documentation
+       ("pkg-config" ,pkg-config)
+       ("qjson", qjson))) ; used for the tests
     (inputs
-     `(("qjson", qjson)
-       ("qt" ,qt-4)))
+     `(("qt" ,qt-4)))
     (arguments
-     `(#:tests? #f ; no check target
-       #:configure-flags
-        '("-DWITH_DOC=OFF"))) ; FIXME: drop once input doxygen is available
+     `(#:tests? #f)) ; no check target
     (home-page "https://launchpad.net/libdbusmenu-qt/")
     (synopsis "Qt implementation of the DBusMenu protocol")
     (description "The library provides a Qt implementation of the DBusMenu