summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-23 14:32:43 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-23 16:29:20 +0100
commitec2da92c96de39c531ea86c4fbad80ea6b55e609 (patch)
tree1240b8a025f20be604a2f920c03875d9a1f8ceb3 /gnu
parentc44ed26ce78e27b625f5c53d58037db63822f5e4 (diff)
downloadguix-ec2da92c96de39c531ea86c4fbad80ea6b55e609.tar.gz
gnu: util-linux: Do not build 'kill'.
* gnu/packages/linux.scm (util-linux)[source](snippet): Set
  "build_kill=no" in 'configure'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8b73190d90..3d677f2208 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -393,11 +393,11 @@ providing the system administrator with some help in common tasks.")
               (patches (list (search-patch "util-linux-tests.patch")))
               (modules '((guix build utils)))
               (snippet
-               ;; We take the 'logger' program from GNU Inetutils, so remove
-               ;; it from here.  There's no '--disable-logger', hence this
-               ;; hack.
+               ;; We take the 'logger' program from GNU Inetutils and 'kill'
+               ;; from GNU Coreutils.
                '(substitute* "configure"
-                  (("build_logger=yes") "build_logger=no")))))
+                  (("build_logger=yes") "build_logger=no")
+                  (("build_kill=yes") "build_kill=no")))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags '("--disable-use-tty-group"