summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2021-01-18 18:11:42 +0100
committerLudovic Courtès <ludo@gnu.org>2021-01-30 15:36:56 +0100
commiteccd448c020d7c34657f644d37cc674bf05eca0e (patch)
treebe1360f3935447c7852910d3e2e51c3a79d50425 /gnu
parentf7a98af0b9ddadd374761c7a8eec2f86ee385a2e (diff)
downloadguix-eccd448c020d7c34657f644d37cc674bf05eca0e.tar.gz
gnu: Add julia-orderedcollections.
* gnu/packages/julia-xyz.scm (julia-orderedcollections): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 7836489e15..ab5bba1bda 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -43,3 +43,25 @@ between older and newer versions of the Julia language.  The Compat package
 provides a macro that lets you use the latest syntax in a backwards-compatible
 way.")
     (license license:expat)))
+
+(define-public julia-orderedcollections
+  (package
+    (name "julia-orderedcollections")
+    (version "1.3.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaCollections/OrderedCollections.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0sfip1ixghsz91q2s7d62rgzw3gppg42fg6bccxlplqa3hfmbycf"))))
+    (build-system julia-build-system)
+    (home-page "https://github.com/JuliaCollections/OrderedCollections.jl")
+    (synopsis "Associative containers that preserve insertion order")
+    (description "This package implements @code{OrderedDicts} and
+@code{OrderedSets}, which are similar to containers in base Julia.  However,
+during iteration the @code{Ordered*} containers return items in the order in
+which they were added to the collection.")
+    (license license:expat)))