summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-06-25 19:11:18 -0300
committerVinicius Monego <monego@posteo.net>2023-07-29 14:32:57 -0300
commitecdcafc007e3a06647e02e2077e0ff352b38c06f (patch)
tree9a98382df32006b3a059e363dfdcc2ac40890a12 /gnu
parent6b28b9a0201f0d06ecab6414be2ed6bfa2642fc3 (diff)
downloadguix-ecdcafc007e3a06647e02e2077e0ff352b38c06f.tar.gz
gnu: python-msgspec: Regenerate autogenerated file.
* gnu/packages/serialization.scm (python-msgspec)[source]: Add a snippet to
delete autogenerated "msgspec/atof_consts.h".
[arguments]: Add new phase to regenerate that file.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/serialization.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 1f8c128eba..38e75bda98 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -14,6 +14,7 @@
 ;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
 ;;; Copyright © 2023 Alexey Abramov <levenson@mmer.org>
 ;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2023 Vinicius Monego <monego@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -628,6 +629,11 @@ RPC system.  Think JSON, except binary.  Or think Protocol Buffers, except faste
                     (url "https://github.com/jcrist/msgspec")
                     (commit version)))
               (file-name (git-file-name name version))
+              (modules '((guix build utils)))
+              (snippet
+               ;; Delete autogenerated file, regenerate in a phase.
+               '(begin
+                  (delete-file "msgspec/atof_consts.h")))
               (sha256
                (base32
                 "09q567klcv7ly60w9lqip2ffyhrij100ky9igh3p3vqwbml33zb3"))))
@@ -645,7 +651,12 @@ RPC system.  Think JSON, except binary.  Or think Protocol Buffers, except faste
                        (invoke "versioneer" "install")
                        (substitute* "setup.py"
                          (("version=versioneer.get_version\\(),")
-                          (format #f "version=~s," #$version))))))))
+                          (format #f "version=~s," #$version)))))
+                   (add-after 'versioneer 'atof-consts
+                     (lambda _
+                       (with-directory-excursion "scripts"
+                         ;; Regenerate the autogenerated file.
+                         (invoke "python" "generate_atof_consts.py")))))))
     (native-inputs (list python-attrs
                          python-gcovr
                          python-msgpack