summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAttila Lendvai <attila.lendvai@gmail.com>2023-09-27 17:47:28 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-10-03 16:02:02 +0200
commited363d6ddbd36f37524af35ab5961ea72c1de62c (patch)
tree49a43e1703c50236137f18eb676283b2788db187 /gnu
parent8036852533b26ce48e82272042ee3ac2a9974ec5 (diff)
downloadguix-ed363d6ddbd36f37524af35ab5961ea72c1de62c.tar.gz
gnu: python-trezor: Update to 0.13.7.
* gnu/packages/finance.scm (python-trezor): Update to 0.13.7.
  [propagated-inputs]: Drop python-click-7 kludge, add
  python-construct-classes instead of python-construct.
  [native-inputs]: Add python-pillow, python-simple-rlp and python-wheel.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/finance.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 1711649a08..7f8a1edfe7 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1094,7 +1094,7 @@ Nano dongle.")
 (define-public python-trezor
   (package
     (name "python-trezor")
-    (version "0.13.0")
+    (version "0.13.7")
     (source
      (origin
        (method git-fetch)
@@ -1103,7 +1103,7 @@ Nano dongle.")
              (commit (string-append "python/v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1wy584bxx5p2av4lv1bx9hl1q0b5n7hqz0hnqb9shjriarvl5ckd"))
+        (base32 "13wyl9b15c8iscfakprwfvh2akw180hfqdjww79b78ywz51y7hdh"))
        (modules
         '((guix build utils)
           (srfi srfi-26)
@@ -1129,25 +1129,24 @@ Nano dongle.")
     (build-system python-build-system)
     (propagated-inputs
      (list python-attrs
-           ;; TOOD: Use the latest click version after release 0.13.1 or later
-           ;; is made (see:
-           ;; https://github.com/trezor/trezor-firmware/issues/2199).
-           python-click-7
-           python-construct
+           python-click
+           python-construct-classes
            python-ecdsa
            python-hidapi
            python-libusb1
            python-mnemonic
            python-requests
            python-typing-extensions))
-    (native-inputs
-     ;; For tests.
+    (native-inputs ; Only needed for running the tests
      (list protobuf
            python-black
            python-isort
+           python-pillow
            python-protobuf
            python-pyqt
-           python-pytest))
+           python-pytest
+           python-simple-rlp
+           python-wheel))
     (home-page "https://github.com/trezor/python-trezor")
     (synopsis "Python library for communicating with TREZOR Hardware Wallet")
     (description "@code{trezor} is a Python library for communicating with