summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-21 09:44:33 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-21 09:48:21 +0100
commited3aa002490867793d2d39dd66a6b7ee3b1d2bae (patch)
treef9e71a86c5cbb0b8c65426f1d50bb31cb305968c /gnu
parent5fa60c3e8196d1453ed74cc2fb1d2b707532d55c (diff)
downloadguix-ed3aa002490867793d2d39dd66a6b7ee3b1d2bae.tar.gz
gnu: gnome-shell-extension-paperwm: Use new package style.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-paperwm)[arguments]:
Convert to list of G-Expressions.
[native-inputs]: Drop labels.

Co-authored-by: Justin Veilleux <terramorpha@cock.li>
Co-authored-by: Vivien Kraus <vivien@planete-kraus.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome-xyz.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 399d58ef1b..ae70d0be9f 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1030,19 +1030,19 @@ It uses ES6 syntax and claims to be more actively maintained than others.")
                '(begin (delete-file "schemas/gschemas.compiled")))))
     (build-system copy-build-system)
     (arguments
-     '(#:install-plan
-       '(("." "share/gnome-shell/extensions/paperwm@paperwm.github.com"
-          #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
-                            "\\.xml$" "\\.compiled$" "\\.svg$")))
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'install 'compile-schemas
-           (lambda _
-             (with-directory-excursion "schemas"
-               (invoke "make"))
-             #t)))))
+     (list
+      #:install-plan
+      #~'(("." "share/gnome-shell/extensions/paperwm@paperwm.github.com"
+           #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
+                             "\\.xml$" "\\.compiled$" "\\.svg$")))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'install 'compile-schemas
+            (lambda _
+              (with-directory-excursion "schemas"
+                (invoke "make")))))))
     (native-inputs
-     `(("glib:bin" ,glib "bin"))) ; for glib-compile-schemas
+     (list `(,glib "bin"))) ; for glib-compile-schemas
     (home-page "https://github.com/paperwm/PaperWM")
     (synopsis "Tiled scrollable window management for GNOME Shell")
     (description "PaperWM is an experimental GNOME Shell extension providing