summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-01-31 09:35:19 +0100
committerRutger Helling <rhelling@mykolab.com>2018-01-31 09:42:05 +0100
commitee5402bfce1aa7ffbe9d27ed6b1fe54c2202a4bb (patch)
tree4757f933e8e12f5ef84faad116b0a4940f562c15 /gnu
parent39b4744a07069882f38a86240d22eacb6f19a895 (diff)
downloadguix-ee5402bfce1aa7ffbe9d27ed6b1fe54c2202a4bb.tar.gz
gnu: wine64-staging: Enable Vulkan support.
* gnu/packages/wine.scm (wine64-staging)[arguments]: Add
'hardcode-libvulkan-path phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wine.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 51e0600234..e71538f1b0 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -281,6 +281,14 @@ integrated into the main branch.")
              (string-append "libdir=" %output "/lib/wine64"))
        #:phases
        (modify-phases %standard-phases
+         (add-before 'configure 'hardcore-libvulkan-path
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((libvulkan (string-append (assoc-ref %build-inputs
+                               "vulkan-icd-loader") "/lib/libvulkan.so")))
+               ;; Hard-code the path to libvulkan.so.
+               (substitute* "dlls/vulkan/vulkan_thunks.c" (("libvulkan.so")
+                            libvulkan))
+               #t)))
          (add-after 'install 'copy-wine32-binaries
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((wine32 (assoc-ref %build-inputs "wine-staging"))