summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 19:45:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 20:25:28 +0200
commitf00bf64f79df3d38dc7846058dfd4925905c6e0e (patch)
treec5d69d61f3cfda3b7e3ca5a6ab7e54a97d62abde /gnu
parent5e4f6f30f29c7458b55131fc103bb707afb2f445 (diff)
downloadguix-f00bf64f79df3d38dc7846058dfd4925905c6e0e.tar.gz
gnu: Add texlive-poemscol.
* gnu/packages/tex.scm (texlive-poemscol): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7850193a34..614b0ef61b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10534,6 +10534,31 @@ to typeset Korean letters (Hangul) using the proper fonts. The use of XeLaTeX
 is recommended.")
     (license license:lppl1.3+)))
 
+(define-public texlive-poemscol
+  (package
+    (name "texlive-poemscol")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/poemscol/"
+                   "source/latex/poemscol/"
+                   "tex/latex/poemscol/")
+             (base32
+              "0hz6zsqcvlzcccxywwzwlpp9gsv41g4hc88481vmj313bys77spd")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/poemscol")
+    (synopsis "Typesetting critical editions of poetry")
+    (description
+     "The package offers LaTeX macros for typesetting critical editions of
+poetry.  Its features include automatic linenumbering, generation of separate
+endnotes sections for emendations, textual collations, and explanatory notes,
+special marking for cases in which page breaks occur during stanza breaks,
+running headers of the form @samp{Notes to pp.@: xx-yy} for the notes
+sections, index of titles and first lines, and automatic generation of a table
+of contents.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-polexpr
   (package
     (name "texlive-polexpr")