summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolò Balzarotti <anothersms@gmail.com>2019-12-11 09:19:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-11 12:06:41 +0100
commitf00da07471d3f1e01df07cb1af970faf50e6d622 (patch)
tree85dd465c3294e2e1ef9320cac14f5b45985824f6 /gnu
parent5d387030e8ccc87234a1197cb2bb9fdac1b074ee (diff)
downloadguix-f00da07471d3f1e01df07cb1af970faf50e6d622.tar.gz
gnu: Add r-xmlparsedata.
* gnu/packages/cran.scm (r-xmlparsedata): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 839f6360b5..b3bde41d79 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14719,6 +14719,27 @@ they are often difficult to interpret.  Rex allows you to build complex
 regular expressions from human readable expressions")
     (license license:expat)))
 
+(define-public r-xmlparsedata
+  (package
+    (name "r-xmlparsedata")
+    (version "1.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "xmlparsedata" version))
+       (sha256
+        (base32
+         "0gjr3l5z5dp276lchr2649as1rkj56d2mlvbr66yg393zzw50lsh"))))
+    (properties `((upstream-name . "xmlparsedata")))
+    (build-system r-build-system)
+    (home-page "https://github.com/r-lib/xmlparsedata#readme")
+    (synopsis "Parse data of @code{R} code as an @code{XML} tree")
+    (description
+     "This package provides tools to convert the output of
+@code{utils::getParseData()} to an @code{XML} tree, that one can search via
+@code{XPath}, and is easier to manipulate in general.")
+    (license license:expat)))
+
 (define-public r-sctransform
   (package
     (name "r-sctransform")