summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-02-27 11:28:50 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-01 14:10:14 +0100
commitf01b5299db6031174f05124b843c936388cd872a (patch)
tree5816252ad5177c1945f81e8bb1e76be61e7053fd /gnu
parent9ba8dd3bd2e4385fd099004a395d2a66c629f916 (diff)
downloadguix-f01b5299db6031174f05124b843c936388cd872a.tar.gz
gnu: Add r-rmumps.
* gnu/packages/cran.scm (r-rmumps): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 412b46bc01..a74432a29f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5867,6 +5867,33 @@ matrices.")
 provides an interactive R manager and worker environment.")
     (license license:gpl2+)))
 
+(define-public r-rmumps
+  (package
+    (name "r-rmumps")
+    (version "5.2.1-22")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "rmumps" version))
+       (sha256
+        (base32 "18wqy82hwnbiwqcyldg8ci0jmxfiaj65ila0fjzzv40d3kl8hx76"))))
+    (properties `((upstream-name . "rmumps")))
+    (build-system r-build-system)
+    (inputs (list zlib))
+    (propagated-inputs (list r-rcpp))
+    (native-inputs (list gfortran))
+    (home-page "https://www.mumps-solver.org/")
+    (synopsis "Wrapper for MUMPS library")
+    (description
+     "Some basic features of @acronym{MUMPS, Multifrontal Massively Parallel
+sparse direct Solver} are wrapped in a class whose methods can be used for
+sequentially solving a sparse linear system (symmetric or not) with one or
+many right hand sides (dense or sparse).  There is a possibility to do
+separately symbolic analysis, LU (or LDL^t) factorization and system solving.
+Third part ordering libraries are included and can be used: PORD, METIS,
+SCOTCH.")
+    (license license:gpl2+)))
+
 (define-public r-lmoments
   (package
     (name "r-lmoments")