summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-23 08:22:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-23 13:36:46 +0100
commitf0d8d59807587c374f9001c54349481a25139b93 (patch)
tree63f1f6f8e40441571e2d3e4f4576c2b7b860658d /gnu
parent6f6cfb8365e3ef44de5b9f022331c31d84778dea (diff)
downloadguix-f0d8d59807587c374f9001c54349481a25139b93.tar.gz
gnu: r-antiword: Update to 1.3.2.
* gnu/packages/cran.scm (r-antiword): Update to 1.3.2.
[source]: Simplify snippet.
[arguments]: Remove trailing #T from build phase.
[synopsis]: Change capitalization.
[description]: Use complete sentences.

Change-Id: I0cffbda247dd57462f89c20a94773f871a029b60
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm45
1 files changed, 20 insertions, 25 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index acc3273831..fbd174c607 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -38258,20 +38258,18 @@ or into raw bitmap vectors for further processing in R.")
 (define-public r-antiword
   (package
     (name "r-antiword")
-    (version "1.3.1")
+    (version "1.3.2")
     (source
-      (origin
-        (method url-fetch)
-        (uri (cran-uri "antiword" version))
-        (sha256
-          (base32
-            "123v8zlczwh6fr1v3x7dl3885xlmddq1bqlcxih8zh07w0hlk1k2"))
-      (modules '((guix build utils)))
-      (snippet
-       '(begin
-           ;; unvendor libantiword
-          (delete-file-recursively "src")
-          #t))))
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "antiword" version))
+       (sha256
+        (base32
+         "1z1xfr2pb1k1k2v65l4bby4smkqg20i22jkvqzw4y2487gndx4cx"))
+       (modules '((guix build utils)))
+       ;; unvendor libantiword
+       (snippet
+        '(delete-file-recursively "src"))))
     (properties `((upstream-name . "antiword")))
     (build-system r-build-system)
     (arguments
@@ -38279,21 +38277,18 @@ or into raw bitmap vectors for further processing in R.")
        (modify-phases %standard-phases
          (add-after 'unpack 'use-system-antiword
            (lambda* (#:key inputs #:allow-other-keys)
-            (substitute* "R/antiword.R"
-             (("system.file\\(\"bin\", package = \"antiword\"\\)")
-              (string-append "\"" (assoc-ref inputs "antiword") "/bin\"")))
-             #t)))))
+             (substitute* "R/antiword.R"
+               (("system.file\\(\"bin\", package = \"antiword\"\\)")
+                (string-append "\"" (assoc-ref inputs "antiword") "/bin\""))))))))
     (inputs (list antiword))
     (propagated-inputs (list r-sys))
-    (home-page
-      "https://github.com/ropensci/antiword#readme")
-    (synopsis
-      "Extract Text from Microsoft Word Documents")
+    (home-page "https://github.com/ropensci/antiword#readme")
+    (synopsis "Extract text from Microsoft Word documents")
     (description
-      "Wraps the @code{AntiWord} utility to extract text from Microsoft Word
-documents.  The utility only supports the old @code{doc} format, not the new
-xml based @code{docx} format.  Use the @code{xml2} package to read the
-latter.")
+     "This package wraps the @code{AntiWord} utility to extract text from
+Microsoft Word documents.  The utility only supports the old @code{doc}
+format, not the new XML based @code{docx} format.  Use the @code{xml2} package
+to read the latter.")
     (license license:gpl2)))
 
 (define-public r-readtext