summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-07-30 10:32:00 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-03 17:38:11 +0800
commitf160a1bfae6df3f36cde3ac8ad325dc0afdc1246 (patch)
tree5c7b93d3ca9a62f376bc92c7c3d31541eb752cb1 /gnu
parent16a4b7a6ff9456dd2d7dc67e520be820eea747d6 (diff)
downloadguix-f160a1bfae6df3f36cde3ac8ad325dc0afdc1246.tar.gz
gnu: kgpg: Update to 23.04.3.
* gnu/packages/kde-pim.scm (kgpg): Update to 23.04.3.
[arguments]<#:phases>: Enable all tests with $HOME set.
[native-inputs]: Remove dbus, add pkg-config.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-pim.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 263940a8d6..5824a391b8 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -897,27 +897,28 @@ package.")
 (define-public kgpg
   (package
     (name "kgpg")
-    (version "22.08.1")
+    (version "23.04.3")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://kde/stable/release-service/" version
                            "/src/kgpg-" version ".tar.xz"))
        (sha256
-        (base32 "1xs0w6lxwq3hzs8r1cwmygcjilbgwa8zpjxwj6zz1wmbg04gqk36"))))
+        (base32 "1ihxw1s4sq7cp5pm6rddcmvqk0v5gfg4v38b6yg8hyjg655x63jz"))))
     (build-system qt-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "dbus-launch" "ctest" "-E" ;; FIXME: Failing tests.
-                       "(kgpg-import|kgpg-disable)")))))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (setenv "HOME" (getcwd))
+                     (invoke "ctest")))))))
     (native-inputs
-     (list extra-cmake-modules gnupg ;; TODO: Remove after gpgme uses fixed path
-           dbus ;; Remove after failing test passes
-           kdoctools))
+     (list extra-cmake-modules
+           gnupg ;; TODO: Remove after gpgme uses fixed path
+           kdoctools
+           pkg-config))
     (inputs
      (list akonadi
            akonadi-contacts