summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-02-23 14:34:33 +0100
committerLudovic Courtès <ludo@gnu.org>2023-02-23 16:31:35 +0100
commitf30946ce13ab7619ac3747db18003de61a0a651b (patch)
tree68eae535cfacb0adb7314d33d5d0289b801b8728 /gnu
parent73c738bc9e5374a1dc38237dfc067fa2c320d5bd (diff)
downloadguix-f30946ce13ab7619ac3747db18003de61a0a651b.tar.gz
gnu: ibutils: Use gexps.
* gnu/packages/fabric-management.scm (ibutils)[arguments]: Use gexps.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fabric-management.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/fabric-management.scm b/gnu/packages/fabric-management.scm
index 09e4a2b854..dc32b163da 100644
--- a/gnu/packages/fabric-management.scm
+++ b/gnu/packages/fabric-management.scm
@@ -164,10 +164,12 @@ interface to this library is not guaranteed to be stable.")
                   perl))
     (native-inputs (list swig))
     (arguments
-     `(#:configure-flags
-       (list (string-append "--with-osm="  (assoc-ref %build-inputs "opensm"))
-             (string-append "--with-tk-lib=" (assoc-ref %build-inputs "tk") "/lib")
-             "--disable-static")))
+     (list #:configure-flags
+           #~(list (string-append "--with-osm="
+                                  #$(this-package-input "opensm"))
+                   (string-append "--with-tk-lib="
+                                  #$(this-package-input "tk") "/lib")
+                   "--disable-static")))
     (synopsis "InfiniBand network utilities")
     (description "These command-line utilities allow for diagnosing and
 testing InfiniBand networks.")