summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-12 12:55:51 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:41 +0200
commitf3b13d4e0e19ffa7bc9ef4de6df2059479e99156 (patch)
tree4e4ff3c3d4158d0d223255cddc4f2417afc2c10a /gnu
parent80fffdcd9cbb0bfe6819fec443f082fdcb4abf44 (diff)
downloadguix-f3b13d4e0e19ffa7bc9ef4de6df2059479e99156.tar.gz
gnu: rust: Use %gcc-search-paths.
* gnu/packages/rust.scm (rust-1.55)[native-search-paths]: Replace list
with factorized %gcc-search-paths.

Change-Id: I0052aa748d45b2302e86589e0e9bfe1ddc0c6aa3
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rust.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index dbc16a02ab..b873437458 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -57,6 +57,7 @@
   #:use-module (guix build-system cargo)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
+  #:use-module (guix search-paths)
   #:use-module (guix download)
   #:use-module (guix memoization)
   #:use-module (guix git-download)
@@ -508,18 +509,8 @@ ar = \"" binutils "/bin/ar" "\"
      `(("llvm" ,llvm-13)
        ("openssl" ,openssl)))
     ;; rustc invokes gcc, so we need to set its search paths accordingly.
-    ;; Note: duplicate its value here to cope with circular dependencies among
-    ;; modules (see <https://bugs.gnu.org/31392>).
     (native-search-paths
-     (list (search-path-specification
-            (variable "C_INCLUDE_PATH")
-            (files '("include")))
-           (search-path-specification
-            (variable "CPLUS_INCLUDE_PATH")
-            (files '("include/c++" "include")))
-           (search-path-specification
-            (variable "LIBRARY_PATH")
-            (files '("lib" "lib64")))))
+      %gcc-search-paths)
     (supported-systems (delete "i586-gnu" %supported-systems))
     (synopsis "Compiler for the Rust programming language")
     (description "Rust is a systems programming language that provides memory