summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:43 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:21 +0200
commitf41078c34b9eed629ec7ee3fa9716ab219012b02 (patch)
tree4a3fe698d737933941aabef80173abbfa38aca53 /gnu
parent2d1728f3e73b706cdb06509fbd36d3ec1f69a7bf (diff)
downloadguix-f41078c34b9eed629ec7ee3fa9716ab219012b02.tar.gz
gnu: Add texlive-spreadtab.
* gnu/packages/tex.scm (texlive-spreadtab): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d3b52b69bc..6c8a3cff58 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96291,6 +96291,26 @@ and the generated PDF files.  Predefined templates for PANTONE and HKS colour
 spaces are included but new ones can easily be defined.")
     (license license:lppl)))
 
+(define-public texlive-spreadtab
+  (package
+    (name "texlive-spreadtab")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/spreadtab/"
+                   "tex/latex/spreadtab/")
+             (base32
+              "052is9kyikixfga67ab3fl8rk8whmvpwgzy02z75awhn164fk2zq")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/spreadtab")
+    (synopsis "Spreadsheet features for LaTeX tabular environments")
+    (description
+     "The package allows the user to construct tables in a manner similar to
+a spreadsheet.  The cells of a table have row and column indices and these can
+be used in formulas to generate values in other cells.")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar