summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2023-07-15 13:43:18 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-02 22:27:41 +0800
commitf49a5ddf89f0fb6eb2dbb272cb975276f1019e18 (patch)
tree00c5a0e0185525d1aa3e1dcd1eb6a25104551ec9 /gnu
parent9579022987b141500386dc0addf322fa8f4e1624 (diff)
downloadguix-f49a5ddf89f0fb6eb2dbb272cb975276f1019e18.tar.gz
gnu: khelpcenter: Use G-expressions.
* gnu/packages/kde-systemtools.scm (khelpcenter)[arguments]:
Rewrite as G-expressions.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-systemtools.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/kde-systemtools.scm b/gnu/packages/kde-systemtools.scm
index 52a711a1bb..3a2d0e6cd3 100644
--- a/gnu/packages/kde-systemtools.scm
+++ b/gnu/packages/kde-systemtools.scm
@@ -26,6 +26,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix utils)
+  #:use-module (guix gexp)
   #:use-module (gnu packages)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages freedesktop)
@@ -164,17 +165,17 @@ Dolphin with the version control systems: Bzr, Git, Mercurial, Subversion.")
            qtbase-5
            xapian))
     (arguments
-     `(#:tests? #f  ;; 1/1 test fails
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'wrap-executable
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out")))
-               ;; Since qt-wrap selectors do not wrap for /share/kf5
-               ;; directories, we need this so khelpcenter can find html4.css.
-               (wrap-program (string-append out "/bin/khelpcenter")
-                 `("XDG_DATA_DIRS" suffix
-                   (,(string-append (assoc-ref inputs "khtml") "/share"))))))))))
+     (list #:tests? #f ;;1/1 test fails
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'install 'wrap-executable
+                          (lambda* (#:key inputs #:allow-other-keys)
+                            ;; Since qt-wrap selectors do not wrap for /share/kf5
+                            ;; directories, we need this so khelpcenter can find html4.css.
+                            (wrap-program (string-append #$output
+                                                         "/bin/khelpcenter")
+                              `("XDG_DATA_DIRS" suffix
+                                (,(string-append (assoc-ref inputs "khtml")
+                                                 "/share")))))))))
     (home-page "https://apps.kde.org/khelpcenter/")
     (synopsis "KDE documentation viewer")
     (description "KHelpCenter uses meta data files which describe the