summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-23 16:03:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:34 +0300
commitf4b37a4bd2c72a8742bc5af0132d259c513e78b8 (patch)
treed1cc8ed2fc510512b38b5d1281901092b35a864b /gnu
parenta55cea13f432deec98ef5d5aa75916793db8f4d1 (diff)
downloadguix-f4b37a4bd2c72a8742bc5af0132d259c513e78b8.tar.gz
gnu: Add rust-objc2-0.3.
* gnu/packages/crates-io.scm (rust-objc2-0.3): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2cedf43120..ddd48cdd88 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39811,6 +39811,33 @@ Foundation framework.")
      "This package provides utilities for testing Objective-C interop.")
     (license license:expat)))
 
+(define-public rust-objc2-0.3
+  (package
+    (name "rust-objc2")
+    (version "0.3.0-beta.3")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "objc2" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0jfnrwmp6n2d6snlpcyfk9l41nhm50wj9h42b6hqj2rxbm1facgy"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-block2" ,rust-block2-0.2)            ; 0.2.0-alpha.6
+        ("rust-objc-sys" ,rust-objc-sys-0.2)        ; 0.2.0-beta.2
+        ("rust-objc2-encode" ,rust-objc2-encode-2)  ; 2.0.0-pre.2
+        ("rust-objc2-proc-macros" ,rust-objc2-proc-macros-0.1)
+        ("rust-uuid" ,rust-uuid-1))))
+    (home-page "https://github.com/madsmtm/objc2")
+    (synopsis
+     "Objective-C interface and bindings to the Cocoa Foundation framework")
+    (description "This package provides Objective-C interface and bindings to
+the Cocoa Foundation framework.")
+    (license license:expat)))
+
 (define-public rust-objc2-encode-2
   (package
     (name "rust-objc2-encode")